Sections: Vom Anfänger zum Profi... | Offene Fragen |

Vom Anfänger zum Profi... ^

Siehe auch: EclipseIDEfuerVisualStudioFans

Der Umgang mit der Eclipse-IDE ('Integrated Development Environment') gehört nicht zum Prüfungsstoff, da an der Prüfung keine Computer eingesetzt werden. Deren Beherrschung könnte jedoch einige Übungsstunden und lange Projektnächte in Zukunft verkürzen!

Der Umgang mit Werkzeugen ist wohl für jeden Berufsstand sehr wichtig. Das gilt auch für Programmierer. Wir haben nun den Verdacht, dass manche Programmierer kaum mehr als die Grundfunktionalitäten z.B. der Eclipse IDE beherrschen (siehe Wikipedia: http://de.wikipedia.org/wiki/Eclipse_(IDE)). Daher hat MirkoStocker in seinem Blog ein paar Artikel darüber geschrieben (siehe Aufgabe 3 ff.). Zunächst aber nochmals einiges Grundlegendes:

Tastaturkürzel:

  1. Einstellungen (von StefanKeller)
    • Javadoc lokal statt übers Web: Preferences > Java > Installed JREs (Voraussetzung dazu sind lokal ausgepackte JDK Javadoc-Dateien).
    • Bessere Tastaturkürzel: Siehe Window > Preferences > General > Keys ...
      • Wortvervollständigung: Edit "Edit Word Completion" zusätzlich zu Alt-/ auch Ctrl-Tab.
      • Run Java Application: Edit "Run Java Application" zusätzlich zu Alt-Shift-X,J auch Ctrl-R (das ist per Default 'Run to line')
  2. Tägliches Arbeiten... (von StefanKeller)
    • Code Format: Ab und zu den Code schön Formatieren (Kontext-Menü > Source)!
    • Aufgabenliste (Tasks): In generiertem Codes steht oft /** TODO: ... */. Diese TODOs können in einer Aufgabenliste verwaltet werden. Dazu muss die Task-View aktiviert werden: Window > Show View > Tasks.
    • Bookmarks: Das sind Buchzeichen, wo man sich Stellen merkt, die man rasch wieder finden möchte. Das funktioniet ähnlich wie Tasks (TODOs): Aktivieren über Window > Show View > Other > Basic > Bookmarks.
    • Notizblock (Scrapbook): 1. Eine leere Kritzelseite erzeugen: File > New > Other...; 2. Namen angeben (Dateierweiterung ist .jpage); 3. Abschnitt selektieren und rechte Maustaste Execute.
  3. Arbeiten mit Workingsets: Wie arbeitet man mit verschiedenen Projekten und behält die Übersicht? Mehr dazu in diesem Blog...
  4. Navigation im Projekt: Wie öffnet man schnell Java-Klassen oder allg. Dateien (sog. Projekt-Resourcen)? Mehr dazu in diesem Blog...
  5. Debugger: Wie kann man Breakpoints setzen? Wie geht Step-Into und Step-Over? etc. Mehr dazu in diesem Blog...
  6. Komprimierter Package Explorer: http://blog.misto.ch/archives/274
  7. Task Focused UI mit Mylyn (früher Mylar): http://blog.misto.ch/archives/272
  8. Scrapbook: Mit "File > New > Other..." kann man im Wizard "Java Run/Debug > Scrapbook Page" eine Datei mit der Endung .jpage erzeugen lassen. Diese öffnet eine View, in der man Java-Code-Fragmente ausführen kann (Code mit Maus selektieren und Ctrl-U oder Menu).

Weiteres rund um Eclipse:

Offene Fragen ^